etherFAX Ends Support for TLS 1.0

By June 1, 2018Uncategorized

etherFAX will no longer be supporting TLS version 1.0 for secure communications after June 30th, 2018. In order to align with security industry best practices and changing regulatory requirements, this change will be made for all of etherFAX’s Internet facing web sites and systems.

What is TLS 1.0?
TLS stands for “Transport Layer Security.” It is a protocol that provides privacy and data integrity between two communicating applications. It is the most widely deployed security protocol used today and is used for web browsers, FTP clients, and other applications that require data to be securely exchanged over a network. TLS ensures that a connection to a remote endpoint is the intended endpoint through encryption and endpoint identity verification. The versions of TLS, to date, are TLS 1.0, 1.1, and 1.2.
Client web browsers, FTP clients, and connection applications may use TLS as a component of their security.
etherFAX highly recommends the use of TLS 1.2 for all communications.

What is the change?
All etherFAX API’s are requiring action to disable TLS 1.0 by June 30, 2018. On that date etherFAX will disable support for the TLS 1.0 encryption protocol, which will prevent customers from using it to access etherFAX services. This change is important to protect the security of our customer’s data while they interact with our systems.

How will customers be impacted?
After etherFAX disables TLS 1.0, any connections to/from etherFAX that rely on TLS 1.0 will fail. This may impact a number of etherFAX services including all REST and SOAP API interfaces, fax server connections, customer portals, and partner portals. After this change the minimum supported Microsoft OS is Windows Server 2008 R2. Server 2003 will cease to function. etherFAX A2E devices are not affected by this change.

How can customers avoid a service disruption?
The action required by your organization will depend on the method by which the etherFAX services are accessed and from what OS version they are being accessed from. Ingenium Customers utilizing a fax server application or etherFAX API integration should contact us for more details on any required changes or updates.

Resources:
etherFAX has made available a test tool which can validate your Windows server(s) for their ability to connect over the various TLS protocols. This tool can only tell you whether your system is capable of properly making connections post-TLS-1.0, using .NET applications. If your faxing application is hardcoded to use legacy protocols, not based on .NET 4.0 or higher, OR based on .NET but not utilizing .NET’s connection methods, we cannot determine whether it will connect to etherFAX endpoints after June 30th, and this should be discussed with the developer or software vendor for further information. You can download the tool here: TLSTester